题目链接

PROBLEM

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σ x∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

1
2
3
4
4  50 2  10 1   20 2   30 1

7 20 1 2 1 10 3 100 2 8 2
5 20 50 10

Sample Output

1
2
80
185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

题意: 给出一组数据p,d p是价值,d是这件物品最后卖出去的时间。 问最大价值是多少?

坑点:不一定非要等到在最后期限才能卖出去, 可以提前卖。(但是能晚卖就晚卖)

思路:

  1. 贪心, 按价值排序, 然后再找最合适的一天卖出去(就是从期限开始向前遍历, 如果那个时间没被标记过, 就可以卖)
  2. 用并查集优化(还是看的kuangbin的博客 才发现如此神奇的做法), 这里并查集起到链表的作用。
    例如: (用f[i] = i 初始化) 给出两组数据 30 5, 20 5 一开始先遇到30 5 这组数据(因为30大 , 在前面)此时 5的祖先是5 > 0 所以这个可以获得, 并且令5的祖先减一, 也就是4。 然后看第二组数据, 此时5的祖先是4 > 0所以也可以获得。

未用并查集优化的代码:

评测结果

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
//#include <bits/stdc++.h>
#include <iostream>
#include "algorithm"
#include "cstdio"
#include "queue"
#include "set"
#include "cstring"
#include "string"
#define esp 1e-6
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int INF = 0x3f3f3f3f;
const int N = 1e5 + 5;

struct node{
int p, d;
}a[N];

bool cmp(node x, node y){
return x.p > y.p;

}
int vis[N];

int main(){
int n;
while(cin >> n){
memset(vis, 0, sizeof vis);
for (int i = 1; i <= n; i++){
scanf("%d%d", &a[i].p, &a[i].d);
}
ll ans = 0;
sort(a + 1, a + n + 1, cmp);
for (int i = 1; i <= n; i++){
for (int j = a[i].d; j >= 1; j--){ // 遍历天数
if (vis[j] == 0){
ans += a[i].p;
vis[j] = 1; // 莫忘标记
break;
}
}
}
cout << ans << "\n";
}
return 0;
}

并查集优化的代码:

评测结果

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
//#include <bits/stdc++.h>
#include <iostream>
#include "algorithm"
#include "cstdio"
#include "queue"
#include "set"
#include "cstring"
#include "string"
#define esp 1e-6
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int INF = 0x3f3f3f3f;
const int N = 1e5 + 5;

struct node{
int p, d;
}a[N];

bool cmp(node x, node y){
return x.p > y.p;

}
int vis[N], f[N];

int tofind(int x){
if (f[x] != x){
f[x] = tofind(f[x]);
}
return f[x];
}

void init(){
memset(vis, 0, sizeof vis);
for (int i = 0; i <= N; i++){
f[i] = i;
}
}

int main(){
int n;
while(cin >> n){
for (int i = 1; i <= n; i++){
scanf("%d%d", &a[i].p, &a[i].d);
}
init();
ll ans = 0;
sort(a + 1, a + n + 1, cmp);
for (int i = 1; i <= n; i++){
int t = tofind(a[i].d); //
if (t > 0){
ans += a[i].p;
f[t] = t - 1; //注意是对祖先 减一
}
}
cout << ans << "\n";
}
return 0;
}